Dashboard problems

Top problems

Hvac noise in cab

Chevrolet Silverado 1500 2007  140000 miles
I have been hearing a weird noise coming from the dash area. I took it to the dealer and they could not hear it. It is not very loud. If I turn on the air or radio it drowns it out. Once I reach 5 miles and hour the road noise drowns it out. It has been going on for about a month and it does not seem to be getting worse. I planning a 2000 mile trip soon and I want to make sure this nothing serious. I have a video file that I will try to upload here and I plan on visiting the dealership tomorrow. Any suggestions? Fire away.
Skyking75 from United States 4 years ago  
SK
2 answers 
Skyking75 from United States 4 years ago
I just posted a video that captures the Noise
Comment

4l60e transmission problem

Chevrolet Silverado 1500 2007 lt crewcab 4.8 214696 miles
Bought the truck used, it ran fine for bout a year then transmission starts acting strange. Wouldnt shift out of second gear, troublecode po967, low voltage shift solenoid b. I changed that still no imporovement. Changed ignition switch cuz everyone was saying it had a voltage drop at the switch, still didnt fix it. I found a bad ground wire so i fixed that, kind of improved but now the speedometer doesnt work sometimes and when it isnt working it wont shift out of second gear. But when it is working i have to shift manually for it to work correctly other wise when taking off from a stop it will start off in 3rd gear. Troublecode still only shows p0967. One other thing aotomatic door locks dont work
youngblood48 from United States 3 years ago  
YO

My battery is draining.

Chevrolet Silverado 1500 2009 1500 V8 5.3L 265746 miles
Well it all started one day when i went to the store for lunch turned off my truck went in then came back out, went to start my truck the dash came on as normal, then when i went to start it i turned the key and lost all power everything was gone i coulndt even us my remote to lock/unlock. I tried boosting it and nothing you could just hear the starter click. Eventually i got it towed home took out the battery charged it put it back in and it worked. Then it sat over night about 12hrs and the same thing lost all power. I have checked my alternator its good checked the fuses the seem good. But… Read complete
Fath from Canada 4 years ago  
FA
Problems with a Silverado 1500? Share them
Submit commentCancel
Submit replyCancel

Do you like StartMyCar? Follow us on Facebook


Did you find the website helpful?

Thank you!